まこと の ブログ

MaKoTo no burogu — Journal de bord…

Aller au contenu | Aller au menu | Aller à la recherche

Clé TNT et EeePC 901 -1-

Etant un heureux possesseur d'une Clé TNT pinnacle PCTV nano, installée grâce au tuto très facile de l'excellent Ubuntu-fr.org, je me suis demandé pourquoi sur mon Eeepc installé sous la distribution Ubuntu-eee (Hardy 8.04.1 avec noyau optimisé eeepc) la Webcam intégrée ne fonctionnait plus... En réfléchissant, je me suis dit " c'est depuis l'installation de la clé TNT :( "

Parlons d'abord de l'installation de la clé TNT pour Ubuntu 8.04 :

Webcam-1245868987.png
A ce stade, si l'on branche la clé TNT, elle ne s'active pas ...




  • Tout d'abord installer make, gcc, build-essential ainsi que les headers qui correspondent à votre noyau, qui serviront à compiler les sources du pilote.
sudo apt-get install make gcc build-essential linux-headers-$(uname -r)
  • Installation du driver :
wget http://linuxtv.org/hg/v4l-dvb/archive/tip.tar.gz
tar -xvzf tip.tar.gz
cd v4l-dvb-*
make
sudo make unload
sudo make install
  • Installation du firmware
cd /lib/firmware
sudo wget http://www.wi-bw.tfh-wildau.de/~pboettch/home/files/dvb-usb-dib0700-1.20.fw
  • Démarrer cette nouvelle configuration
sudo depmod

Webcam-1245868539.png


Enfin, débrancher-rebrancher la clé TNT.
La clé devrait alors s'activer

Sinon, faire un dmesg pour voir ce qui se passe...





Parlons maintenant de la webcam intégrée :

De base avec Ubuntu-eee sur un EeePC901, tout le matériel fonctionne... donc la webcam marche à merveille sur Cheese (faut l'activer dans le bios hein! ou via eee-control), et si on installe VLC 9, on peut y afficher la video (/dev/video0) dans la partie V4l2 (ne marche pas sur VLC 8 avec V4L).

Bref, tout fonctionne jusqu'au moment où j'installe la Clé TNT Pinnacle Nano.
Téléchargement, et compilation des pilotes comme ci-dessus, tout çà... avec Kaffeine, la TNT marche super ^^ Sauf que... la webcam ne marche plus ...
Au lancement de Cheese, plus d'image :(

J'ai donc voulu remettre les pilotes de webcam, mais aucun changement positif :

sudo modprobe uvcvideo
FATAL: Error inserting uvcvideo (/lib/modules/2.6.24-19-eeepc/ubuntu/media/usbvideo/uvcvideo.ko): Unknown symbol in module, or unknown parameter (see dmesg)

Pas moyen de lancer le module.

En recherchant une solution, je suis tombé sur cette page : http://pagesperso-orange.fr/gja.frndz/eeepc/dualxanu.htm#tntcam, expliquant le process à suivre pour réparer le pilote de Webcamera. la procédure fonctionne (bien que quelque peu cavalière et très dangereuse !!! le truc à pas faire selon moi cf. lancer nautilus en mode superutilisateur (gksudo nautilus) et mettre le mode UTILISATEUR ATTENTIF en route... alors que c'est simple en ligne de commande), mais évidemment, après çà, c'est la TNT qui ne fonctionne plus...

J'ai alors écris deux scripts reprenant les commandes nécessaires pour activer la Webcam, ou la TNT.
Je les écris demain.
À suivre…

Ajouter un commentaire

Les commentaires peuvent être formatés en utilisant une syntaxe wiki simplifiée.

Fil des commentaires de ce billet