まこと の ブログ

MaKoTo no burogu — Journal de bord…

Aller au contenu | Aller au menu | Aller à la recherche

Mot-clé - Dépannage

Fil des billets - Fil des commentaires

mercredi, 16 septembre 2015

Dépanner une manette de jeu

Une petite vidéo :)


Et bien sûr, revissez tout ça avec la bonne technique !!!

lundi, 8 septembre 2014

Module Camera Pi défectueux

modulecampi.jpg

  • Dernièrement je cherchais à faire du flux vidéo avec une webcam et un Raspberry Pi, mais malheureusement, ma « webcam Philips de l'an 2000 gagnée au concours des net d'or de France Télécom » (oui je dois toujours remettre mon vieux site en ligne ^^;) qui pourtant fonctionne comme un charme sous n'importe quel GNU/Linux, ne fonctionnait pas avec le Pi.

Même pas une question d'alimentation, juste une incompatibilité hardware qui reset la caméra dés qu'on lui demande quelque chose.(Philips PCVC675K)

J'ai alors voulu voir pour une webcam, une HD tant qu'à faire, et vraiment de me rendre compte que l'USB était bien trop lent pour streamer quelque chose de correct en HD en terme de débit d'image et de qualités de celles-ci.

Je me suis alors souvenu du Module Camera pour la Raspberry, qui, pour moins cher qu'une webcam, est capable de capturer de la HD à grande vitesse sur le port prévu à cet effet !

Hop, j'en acquiert donc un et me met au boulot…

  • J'installe une Raspbian toute fraîche (2014-06-20-wheezy-raspbian), et j'active la caméra à l'étape raspi-config, puis je mets à jour :
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install rpi-update
sudo rpi-update
  • Je m'en vais tester la caméra avec la simple commande :
raspistill -o image.jpg
  • Rien ne se passe… puis s'affiche ceci :
mmal received unexpected camera control callback event, 0x4f525245

Allons bon… qu'est-ce qui va pas encore ! Un problème de version ?

rpi-update 1b9a0011

Toujours rien… Rahhh mais euuuuuu j'ai beau tenter plein de trucs, refaire et vérifier les branchements, tester sur ma seconde Raspberry, ça ne veut rien savoir.
La commande raspistill allume bien la led de la cam, mais la commande freeze, la led reste allumée, puis l'erreur est envoyée.

  • Une petit gars gentil, merci das-leben-ist-schoen, à pris la peine de s'inscrire sur ce forum juste pour indiquer qu'après avoir vérifié les modalités d'usages, comme le branchement correct de la nappe, celui du petit connecteur jaune, et quelques commandes comme vcgencmd get_camera, si l'erreur persiste, la solution est tout simplement de remplacer la caméra

Mince alors, les recherches en ligne montrant que je n'étais pas seul dans ce cas, le produit étant neuf, on ne pense pas tout de suite à un défaut de fabrication, et pourtant, il faut bien s'y résoudre malgré la journée perdue à chercher en vain.
À défaut de confirmer avec une seconde caméra qu'on m'aurait prêté, j'ai donc fait appel au SAV qui m'a remplacé le module sans difficulté !

  • Problème réglé !

C'est rare de tomber en panne après l'achat mais ça arrive quand même, d'où l'importance pour certains types de produits de bien choisir l'enseigne du magasin.

samedi, 22 mars 2014

HackTV

dsc09297.jpg

  • Un téléviseur en panne ?

Plus où moins… En fait on m'a fait don de cette télé qui fonctionne plutôt bien malgré la piètre qualité des couleurs…
Sauf qu'en basculant sur les canaux AV1 et AV2 ou encore S-VHS, un horrible sifflement se fait entendre, qu'une source vidéo soit connectée ou non, et quelque soit le réglage du volume sonore.
Bruit parasite strident qui cesse dés qu'on remet la TV sur son tuner… Étonnant !

J'ai alors entrepris d'ouvrir l'engin et de trouver un défaut évident, mais rien de probant.
De plus, impossible d'identifier la marque et le modèle du châssis, de ce TV DUAL ETV 70440.
À force de recherches sur le circuit et sur internet, j'ai fini par comprendre qu'il s'agissait en fait d'un châssis standard de type E9.
Sur une base commune, les fabricants de TV pouvaient donc distribuer leurs produits avec plus où moins d'options, câblées ou non sur ce châssis.
Ensuite il ne restait qu'à dégoter le « Chassis TV Standard E9 Service Manual[1] », permettant de suivre le schéma à la recherche de la panne, mais je n'ai rien trouvé, et au bout de quelques heures, j'en ai eu marre…

  • Une panne à la con que j'ai donc choisi de contourner, en déconnectant simplement des enceintes l'ampli audio du chassis E9, pour le remplacer par un ampli d'enceinte de PC.

J'ai raccordé celui-ci sur les enceintes et la prise casque du TV, puis ajusté le niveau de son amplification de manière cohérente avec le réglage du volume de la prise casque à la télécommande.

Voilà !
dsc09298.jpg dsc09299.jpg

Le Service Manual s'est révélé très utile pour bénéficier de la manipulation à effectuer à la télécommande pour accéder au menu « ingénieur », permettant notamment le réglage de la géométrie de l'image.

Note

[1] dispo en annexe ci-dessous

mardi, 26 novembre 2013

Les trucs qui me paraissent évident… -1-

  • Mais qui pourtant ne le sont pas pour tous le monde !

En effet, parfois je me rends compte en discutant avec mon entourage, à quel point mon parcours peut-être différents, et ce même lorsqu'on partage les mêmes centres d'intérêts.
Dans cette série de billets, je vais donc parler de choses archi-connues de tous, mais à côté desquelles, pour des raisons diverses, vous seriez passés.
Sans compter toutes celles que je ne connais pas…
Rien d'importants, juste des petits détails, de ce genre de choses qui enrichissent, voire simplifie la vie.



Pour commencer, je vais aborder un sujet technique !

Comment re-visser correctement dans du plastique :

En effet, il y a une manière bien particulière de s'y prendre si l'on veut que la fixation soit efficace, surtout si on est amené à dévisser/revisser régulièrement, afin d'assurer la longévité du filetage et éviter de se retrouver avec une vis qui «tourne folle» à l'infini.

Que se passe t-il lorsqu'après avoir démonté le boitier d'un appareil, on le remonte, en revissant les vis sans précaution ?

Réponse : Une forte chance de creuser un nouveau filetage dans le plastique, et au moment du serrage, d'arracher celui-ci, la structure ayant été fragilisée, et hop, la vis se met à tourner à l'infini sans jamais se bloquer !
Pourquoi ? Ces vis sont de type auto-taraudeuse; lorsque l'appareil est assemblé en usine, le trou du plastique est lisse, et c'est donc la première fois que la vis est vissée dans le trou, que le filetage est creusé dans le plastique, et c'est censé être fait une fois pour toute !

  • L'astuce consiste donc à s'assurer de bien revisser la vis dans le filetage d'origine, ce qui s'effectue simplement en tournant doucement le tournevis en sens inverse tout en effectuant une légère pression. La vis va donc suivre le filetage en sens dévissant et finira par tomber dans un creux, qui est en fait le début de l'hélicoïde. Hop, maintenant on peut visser !

Une petite vidéo pour illustrer ça.
Attention, j'ai amplifié le son pour bien se rendre compte du phénomène.
Parfois c'est plus subtile, et on le ressent sur le manche du tournevis, plus qu'on l'entends.

Merci à Noël, de m'avoir appris ça il y a 15 ans, lors d'une séance improvisée de modélisme.

- page 1 de 3